標籤: 暫無標籤

VLAN(Virtual Local Area Network)的中文名為"虛擬區域網"。VLAN是一種將區域網設備從邏輯上劃分成一個個網段,從而實現虛擬工作組的新興數據交換技術。這一新興技術主要應用於交換機和路由器中,但主流應用還是在交換機之中。但又不是所有交換機都具有此功能,只有VLAN協議的第三層以上交換機才具有此功能,這一點可以查看相應交換機的說明書即可得知。

1 虛擬區域網 -【VLAN的目的】

  VLAN(Virtual Local Area Network,虛擬區域網)技術的出現,主要為了解決交換機在進行區域網互連時無法限制廣播的問題。這種技術可以把一個LAN劃分成多個邏輯的LAN——VLAN,每個VLAN是一個廣播域,VLAN內的主機間通信就和在一個LAN內一樣,而VLAN間則不能直接互通,這樣,廣播報文被限制在一個VLAN內。

2 虛擬區域網 -【VLAN的優點】

  1. 限制廣播域。廣播域被限制在一個VLAN內,節省了帶寬,提高了網路處理能力。
  2. 增強區域網的安全性。不同VLAN內的報文在傳輸時是相互隔離的,即一個VLAN內的用戶不能和其它VLAN內的用戶直接通信,如果不同VLAN要進行通信,則需要通過路由器或三層交換機等三層設備。
  3. 靈活構建虛擬工作組。用VLAN可以劃分不同的用戶到不同的工作組,同一工作組的用戶也不必局限於某一固定的物理範圍,網路構建和維護更方便靈活。

3 虛擬區域網 -【什麼是VLAN】

  VLAN(Virtual Local Area Network)即虛擬區域網,是一種通過將區域網內的設備邏輯地而不是物理地劃分成一個個網段從而實現虛擬工作組的新興技術。IEEE於1999年頒布了用以標準化VLAN實現方案的802.1Q協議標準草案。
  VLAN技術允許網路管理者將一個物理的LAN邏輯地劃分成不同的廣播域(或稱虛擬LAN,即VLAN),每一個VLAN都包含一組有著相同需求的計算機工作站,與物理上形成的LAN有著相同的屬性。但由於它是邏輯地而不是物理地劃分,所以同一個VLAN內的各個工作站無須被放置在同一個物理空間里,即這些工作站不一定屬於同一個物理LAN網段。一個VLAN內部的廣播和單播流量都不會轉發到其他VLAN中,即使是兩台計算機有著同樣的網段,但是它們卻沒有相同的VLAN號,它們各自的廣播流也不會相互轉發,從而有助於控制流量、減少設備投資、簡化網路管理、提高網路的安全性。
  VLAN是為解決乙太網的廣播問題和安全性而提出的,它在乙太網幀的基礎上增加了VLAN頭,用VLAN ID把用戶劃分為更小的工作組,限制不同工作組間的用戶二層互訪,每個工作組就是一個虛擬區域網。虛擬區域網的好處是可以限制廣播範圍,並能夠形成虛擬工作組,動態管理網路。
  既然VLAN隔離了廣播風暴,同時也隔離了各個不同的VLAN之間的通訊,所以不同的VLAN之間的通訊是需要有路由來完成的。

4 虛擬區域網 -【組建VLAN的條件】

  VLAN是建立在物理網路基礎上的一種邏輯子網,因此建立VLAN需要相應的支持VLAN技術的網路設備。當網路中的不同VLAN間進行相互通信時,需要路由的支持,這時就需要增加路由設備——要實現路由功能,既可採用路由器,也可採用三層交換機來完成。

5 虛擬區域網 -【VLAN的劃分】

  1.根據埠來劃分VLAN
  許多VLAN廠商都利用交換機的埠來劃分VLAN成員。被設定的埠都在同一個廣播域中。例如,一個交換機的1,2,3,4,5埠被定義為虛擬網AAA,同一交換機的6,7,8埠組成虛擬網BBB。這樣做允許各埠之間的通訊,並允許共享型網路的升級。但是,這種劃分模式將虛擬網限制在了一台交換機上。
  第二代埠VLAN技術允許跨越多個交換機的多個不同埠劃分VLAN,不同交換機上的若干個埠可以組成同一個虛擬網。
  以交換機埠來劃分網路成員,其配置過程簡單明了。因此,從目前來看,這種根據埠來劃分VLAN的方式仍然是最常用的一種方式。
  2.根據MAC地址劃分VLAN
  這種劃分VLAN的方法是根據每個主機的MAC地址來劃分,即對每個MAC地址的主機都配置它屬於哪個組。這種劃分VLAN方法的最大優點就是當用戶物理位置移動時,即從一個交換機換到其他的交換機時,VLAN不用重新配置,所以,可以認為這種根據MAC地址的劃分方法是基於用戶的VLAN,這種方法的缺點是初始化時,所有的用戶都必須進行配置,如果有幾百個甚至上千個用戶的話,配置是非常累的。而且這種劃分的方法也導致了交換機執行效率的降低,因為在每一個交換機的埠都可能存在很多個VLAN組的成員,這樣就無法限制廣播包了。另外,對於使用筆記本電腦的用戶來說,他們的網卡可能經常更換,這樣,VLAN就必須不停地配置。
  3.根據網路層劃分VLAN
  這種劃分VLAN的方法是根據每個主機的網路層地址或協議類型(如果支持多協議)劃分的,雖然這種劃分方法是根據網路地址,比如IP地址,但它不是路由,與網路層的路由毫無關係。
  這種方法的優點是用戶的物理位置改變了,不需要重新配置所屬的VLAN,而且可以根據協議類型來劃分VLAN,這對網路管理者來說很重要,還有,這種方法不需要附加的幀標籤來識別VLAN,這樣可以減少網路的通信量。
  這種方法的缺點是效率低,因為檢查每一個數據包的網路層地址是需要消耗處理時間的(相對於前面兩種方法),一般的交換機晶元都可以自動檢查網路上數據包的乙太網幀頭,但要讓晶元能檢查IP幀頭,需要更高的技術,同時也更費時。當然,這與各個廠商的實現方法有關。
  4.根據IP組播劃分VLAN
  IP 組播實際上也是一種VLAN的定義,即認為一個組播組就是一個VLAN,這種劃分的方法將VLAN擴大到了廣域網,因此這種方法具有更大的靈活性,而且也很容易通過路由器進行擴展,當然這種方法不適合區域網,主要是效率不高。
  5.基於規則的VLAN
  也稱為基於策略的VLAN。這是最靈活的VLAN劃分方法,具有自動配置的能力,能夠把相關的用戶連成一體,在邏輯劃分上稱為「關係網路」。網路管理員只需在網管軟體中確定劃分VLAN的規則(或屬性),那麼當一個站點加入網路中時,將會被「感知」,並被自己地包含進正確的VLAN中。同時,對站點的移動和改變也可自動識別和跟蹤。
  採用這種方法,整個網路可以非常方便地通過路由器擴展網路規模。有的產品還支持一個埠上的主機分別屬於不同的VLAN,這在交換機與共享式Hub共存的環境中顯得尤為重要。自動配置VLAN時,交換機中軟體自動檢查進入交換機埠的廣播信息的IP源地址,然後軟體自動將這個埠分配給一個由IP子網映射成的VLAN。
  * 以上劃分VLAN的方式中,基於埠的VLAN埠方式建立在物理層上;MAC方式建立在數據鏈路層上;網路層和IP廣播方式建立在第三層上。
  <B>

6 虛擬區域網 -【VLAN的標準】

  </B>
  對VLAN的標準,我們只是介紹兩種比較通用的標準,當然也有一些公司具有自己的標準,比如Cisco公司的ISL標準,雖然不是一種大眾化的標準,但是由於Cisco Catalyst交換機的大量使用,ISL也成為一種不是標準的標準了。
  · 802.10VLAN標準
  在1995年,Cisco公司提倡使用IEEE802.10協議。在此之前,IEEE802.10曾經在全球範圍內作為VLAN安全性的同一規範。Cisco公司試圖採用優化后的802.10幀格式在網路上傳輸FRAMTagging模式中所必須的VLAN標籤。然而,大多數802委員會的成員都反對推廣802.10。因為,該協議是基於FrameTagging方式的。
  · 802.1Q
  在1996年3月,IEEE802.1Internetworking委員會結束了對VLAN初期標準的修訂工作。新出台的標準進一步完善了VLAN的體系結構,統一了Fram-eTagging方式中不同廠商的標籤格式,並制定了VLAN標準在未來一段時間內的發展方向,形成的802.1Q的標準在業界獲得了廣泛的推廣。它成為VLAN史上的一塊里程碑。802.1Q的出現打破了虛擬網依賴於單一廠商的僵局,從一個側面推動了VLAN的迅速發展。另外,來自市場的壓力使各大網路廠商立刻將新標準融合到他們各自的產品中。
  · Cisco ISL 標籤
  ISL(Inter-Switch Link)是Cisco公司的專有封裝方式,因此只能在Cisco的設備上支持。ISL是一個在交換機之間、交換機與路由器之間及交換機與伺服器之間傳遞多個VLAN信息及VLAN數據流的協議,通過在交換機直接的埠配置ISL封裝,即可跨越交換機進行整個網路的VLAN分配和配置。

7 虛擬區域網 -【劃分VLAN的基本策略】

  從技術角度講,VLAN的劃分可依據不同原則,一般有以下三種劃分方法:
  1、基於埠的VLAN劃分
  這種劃分是把一個或多個交換機上的幾個埠劃分一個邏輯組,這是最簡單、最有效的劃分方法。該方法只需網路管理員對網路設備的交換埠進行重新分配即可,不用考慮該埠所連接的設備。
  2、基於MAC地址的VLAN劃分
  MAC地址其實就是指網卡的標識符,每一塊網卡的MAC地址都是惟一且固化在網卡上的。MAC地址由12位16進位數表示,前8位為廠商標識,后4位為網卡標識。網路管理員可按MAC地址把一些站點劃分為一個邏輯子網。
  3、基於路由的VLAN劃分
  路由協議工作在網路層,相應的工作設備有路由器和路由交換機(即三層交換機)。該方式允許一個VLAN跨越多個交換機,或一個埠位於多個VLAN中。
  就目前來說,對於VLAN的劃分主要採取上述第1、3種方式,第2種方式為輔助性的方案。

8 虛擬區域網 -【VLAN技術簡單談】

  區域網的發展是VLAN產生的基礎,所以在介紹VLAN之前,我們先來了解一下區域網的有關知識。
  區域網(LAN)通常是一個單獨的廣播域,主要由Hub、網橋或交換機等網路設備連接同一網段內的所有節點形成。處於
虛擬區域網

同一個區域網之內的網路節點之間可以直接通信,而處於不同區域網段的設備之間的通信則必須經過路由器才能通信。圖1所示即為使用路由器構建的典型的區域網環境。
  隨著網路的不斷擴展,接入設備逐漸增多,網路結構也日趨複雜,必須使用更多的路由器才能將不同的用戶劃分到各自的廣播域中,在不同的區域網之間提供網路互聯。
  但這樣做存在兩個缺陷:
  首先,隨著網路中路由器數量的增多,網路時延逐漸加長,從而導致網路數據傳輸速度的下降。這主要是因為數據在從一個區域網傳遞到另一個區域網時,必須經過路由器的路由操作: 路由器根據數據包中的相應信息確定數據包的目標地址,然後再選擇合適的路徑轉發出去。
  其次,用戶是按照它們的物理連接被自然地劃分到不同的用戶組(廣播域)中。這種分割方式並不是根據工作組中所有用戶的共同需要和帶寬的需求來進行的。因此,儘管不同的工作組或部門對帶寬的需求有很大的差異,但它們卻被機械地劃分到同一個廣播域中爭用相同的帶寬。

9 虛擬區域網 -【VLAN的定義及特點】

  虛擬區域網VLAN是一組邏輯上的設備和用戶,這些設備和用戶並不受物理網段的限制,可以根據功能、部門及應用等因素將它們組織起來,相互之間的通信就好像它們在同一個網段中一樣,由此得名虛擬區域網。VLAN是一種比較新的技術,工作在OSI參考模型的第2層和第3層,一個VLAN就是一個廣播域,VLAN之間的通信是通過第3層的路由器來完成的。與傳統的區域網技術相比較,VLAN技術更加靈活,它具有以下優點:
  ● 網路設備的移動、添加和修改的管理開銷減少;
  ● 可以控制廣播活動;
  ● 可提高網路的安全性。

10 虛擬區域網 -【VLAN的分類】

  定義VLAN成員的方法有很多,由此也就分成了幾種不同類型的VLAN。
   1. 基於埠的VLAN
  基於埠的VLAN的劃分是最簡單、有效的VLAN劃分方法,它按照區域網交換機埠來定義VLAN成員。VLAN從邏輯上把區域網交換機的埠劃分開來,從而把終端系統劃分為不同的部分,各部分相對獨立,在功能上模擬了傳統的區域網。基於埠的VLAN又分為在單交換機埠和多交換機埠定義VLAN兩種情況:
虛擬區域網


  (1) 多交換機埠定義VLAN
  如圖3所示,交換機1的1、2、3埠和交換機2的4、5、6埠組成VLAN1,交換機1的4、5、6、7、8埠和交換機2的1、2、3、7、8埠組成VLAN2。
   (2) 單交換機埠定義VLAN
虛擬區域網


  如圖2所示,交換機的1、2、6、7、8埠組成VLAN1,3、4、5埠組成了VLAN2。這種VLAN只支持一個交換機。
  基於埠的VLAN的劃分簡單、有效,但其缺點是當用戶從一個埠移動到另一個埠時,網路管理員必須對VLAN成員進行重新配置。
   2. 基於MAC地址的VLAN
  基於MAC地址的VLAN是用終端系統的MAC地址定義的VLAN。MAC地址其實就是指網卡的標識符,每一塊網卡的MAC地址都是惟一的。這種方法允許工作站移動到網路的其他物理網段,而自動保持原來的VLAN成員資格。在網路規模較小時,該方案可以說是一個好的方法,但隨著網路規模的擴大,網路設備、用戶的增加,則會在很大程度上加大管理的難度。
   3. 基於路由的VLAN
  路由協議工作在7層協議的第3層—網路層,比如基於IP和IPX的路由協議,這類設備包括路由器和路由交換機。該方式允許一個VLAN跨越多個交換機,或一個埠位於多個VLAN中。
   4. 基於策略的VLAN
  基於策略的VLAN的劃分是一種比較有效而直接的方式,主要取決於在VLAN的劃分中所採用的策略。

11 虛擬區域網 -【VLAN發展趨勢】

  目前在寬頻網路中實現的VLAN基本上能滿足廣大網路用戶的需求,但其網路性能、網路流量控制、網路通信優先順序控制等還有待提高。前面所提到的VTP技術、STP技術,基於三層交換的VLAN技術等在VLAN使用中存在網路效率的瓶頸問題,這主要是IEEE802.1Q、IEEE802.1D協議的不完善所致,IEEE正在制定和完善IEEE802.1S(Multiple Spanning Trees)和IEEE802.1W(Rapid Reconfiguration of Spanning Tree)來改善VLAN的性能。採用IEEE802.3z和IEEE802.3ab協議,並結合使用RISC(精簡指令集計算)處理器或者網路處理器而研製的吉位VLAN交換機在網路流量等方面採取了相應的措施,大大提高了VLAN網路的性能。IEEE802.1P協議提出了COS(Class of Service)標準,這使網路通信優先順序控制機制有了參考。

12 虛擬區域網 -【公司內部進行VLAN的劃分實例】

  對於每個公司而言都有自己不同的需求,下面我們給出一個典型的公司的VLAN的實例,這樣也可以成為我們以後為公司劃分VLAN的依據。
  某公司現在有工程部、銷售部、財務部。VLAN的劃分:工程部VLAN10,銷售部VLAN20,財務部VLAN30,並且各部門還可以相互通訊。現有設備如下:CISCO 3640路由器,Cisco Catalyst 2924交換機一台,二級交換機若干台。
  交換機配置文件中的部分代碼如下:
  ......
  !
  interface vlan10
  ip address 192.168.0.1
  !
  interface vlan20
  ip address 192.168.1.1
  !
  interface vlan30
  ip address 192.168.2.1
  !
  ......
  路由器配置文件中的部分代碼如下:
  ......
  interface FastEthernet 1/0.1
  encapsulation isl 10
  ip address 192.168.0.2
  !
  interface FastEthernet 1/0.2
  encapsulation isl 20
  ip address 192.168.1.2
  !
  interface FastEthernet 1/0.3
  encapsulation isl 30
  ip address 192.168.2.2
  !
  ......
  !
  router rip
  network 192.168.0.0
  !

13 虛擬區域網 -【VLAN的標準】

  對VLAN的標準,我們只是介紹兩種比較通用的標準,當然也有一些公司具有自己的標準,比如Cisco公司的ISL標準,雖然不是一種大眾化的標準,但是由於Cisco Catalyst交換機的大量使用,ISL也成為一種不是標準的標準了。  

 · 802.10VLAN標準   在1995年,Cisco公司提倡使用IEEE802.10協議。在此之前,IEEE802.10曾經在全球範圍內作為VLAN安全性的同一規範。Cisco公司試圖採用優化后的802.10幀格式在網路上傳輸FramTagging模式中所必須的VLAN標籤。然而,大多數802委員會的成員都反對推廣802.10。因為,該協議是基於FrameTagging方式的。  

 · 802.1Q   在1996年3月,IEEE802.1Internetworking委員會結束了對VLAN初期標準的修訂工作。新出台的標準進一步完善了VLAN的體系結構,統一了Frame-Tagging方式中不同廠商的標籤格式,並制定了VLAN標準在未來一段時間內的發展方向,形成的802.1Q的標準在業界獲得了廣泛的推廣。它成為VLAN史上的一塊里程碑。802.1Q的出現打破了虛擬網依賴於單一廠商的僵局,從一個側面推動了VLAN的迅速發展。另外,來自市場的壓力使各大網路廠商立刻將新標準融合到他們各自的產品中。  

 · Cisco ISL 標籤   ISL(Inter-Switch Link)是Cisco公司的專有封裝方式,因此只能在Cisco的設備上支持。ISL是一個在交換機之間、交換機與路由器之間及交換機與伺服器之間傳遞多個VLAN信息及VLAN數據流的協議,通過在交換機直接的埠配置ISL封裝,即可跨越交換機進行整個網路的VLAN分配和配置。

上一篇[格拉納達大學]    下一篇 [呸]

相關評論

同義詞:暫無同義詞