評論(0

集成開發環境

標籤: 暫無標籤

集成開發環境(Integrated Development,IDE)。其縮寫形式IDE同時也代指「電子集成驅動器」。 

目錄

1 集成開發環境 -介紹

 

      集成開發環境(簡稱IDE)軟體是用於程序開發環境的應用程序,一般包括代碼編輯器、編譯器、調試器和圖形用戶界面工具。該程序可以獨立運行,也可以和其它程序並用。例如,BASIC語言在微軟辦公軟體中可以使用,可以在微軟Word文檔中編寫WordBasic程序。IDE為用戶使用Visual Basic、Java和PowerBuilder等現代編程語言提供了方便。  

      IDE多被用於開發HTML應用軟體。例如,許多人在設計網站時使用IDE(如HomeSite、DreamWeaver、FrontPage,等等),因為很多項任務會自動生成。


英文資料:Visual Studio Integrated Development Environment (IDE)


When you start a new project in Visual Studio .NET, you will see a group of windows opened within the development environment (one possible layout is shown in Figure 3.4). The following subsections describe each of these windows.

Figure 3.4. Several windows will be open when you start a new Visual Studio .NET project.


Toolbox Window
The Toolbox window contains a list of controls or components that you can drag and drop onto your design surface. The Toolbox window contains several tabs that make different sets of components available, depending on the type of designer active in the editor window (the window in the middle of the environment). If you are designing a Windows Form, you will get a specific set of tools that work with Windows Forms. If you are designing a Web Form, you will get a specific set of tools for working with Web Forms.
If you are designing an XML document, there will be other options you can choose. To view the Toolbox window, select View, Toolbox from the Visual Studio .NET menu bar. Figure 3.5 shows the Toolbox window displaying controls available on Windows Forms.

Figure 3.5. The Toolbox holds a list of controls.


TIP

In addition to providing the standard tools and tabs that Visual Studio .NET provides, you can add tabs, as well as your own code snippets, to the Toolbox. Right-click the Toolbox window to add or delete tabs. You can drag code from the code editor onto the Toolbox, as well, for later use.

If you wish to customize the list of tools displayed in the Toolbox window, or if you wish to add any additional .NET components, ActiveX controls, or third-party controls, choose the Tools, Customize Toolbox menu item to display the Customize Toolbox dialog box, as shown in Figure 3.6 and Figure 3.7. Figure 3.6 shows a list of available COM components, and Figure 3.7 shows the available .NET Framework components.

Figure 3.6. Customize Toolbox lets you add COM components to your Toolbox.


Figure 3.7. Use Customize Toolbox to choose which .NET Framework components
are displayed in the Toolbox window.


Solution Explorer Window
In Visual Studio .NET, a solution is a set of one or more projects that are part of the same application. The Solution Explorer window shows you an expandable list of projects, each project's references, and each project's components. If this window is closed, you can open it by selecting the View, Solution Explorer menu item. Components may be made up of forms, classes, modules, and any other file types it takes to create your application. Double-click an item in order to edit that item within the IDE. Figure 3.8 shows the Solution Explorer window displaying the contents of a sample Windows application solution.

Figure 3.8. The Solution Explorer gives you a graphical representation of all the files that make up your project(s).


The Solution Explorer window displays a series of buttons across its top, and these buttons dynamically change based on the item you have selected in the Solution Explorer window. Table 3.3 describes some of these buttons, starting with the leftmost and proceeding right.

Table 3.3. Buttons on the Solution Explorer Window Button  Description  View Code  Displays the code for the file that has focus in the Solution Explorer  View Designer  Displays the designer for the specific file that has focus in the Solution Explorer  Refresh  Refreshes the Solution Explorer  Show All Files  Displays all files associated with the project, including files normally hidden by Visual Studio  Properties  Displays the Properties window, which shows roperties for the selected file 


Class View Window
When you start creating your own classes, you may want to see a list of all the properties and methods available in those classes. You can use the Class View window, as shown in Figure 3.9, to get an overview of these items. You can bring up this win-dow using the View, Class View menu item.
Once the window is displayed, you can expand each item in the list to see the members of the class. If you choose any of these members, you can right-click and see a menu of actions that apply directly to the definition of that member. Double-click any of the members of the class to display a code window with the item definition displayed in the editor.

Figure 3.9. The Class View is an excellent way to view all the properties and methods of your classes.


Server Explorer Window
The Server Explorer window (accessed using the View, Server Explorer menu) allows you to view the various services available on a particular server.
These services include Crystal Services (for working with crystal reports), Event Logs, Message Queues, Performance Counters, and SQL Servers.

For most of these services, you can drill down and see a list of existing items梐nd you can even add new items. You can drag and drop a service from the Server Explorer window, shown in Figure 3.10, onto a design surface so that you can interact with the element programmatically in your
application. For example, you can drag a performance counter onto a Web Form and use that component to interact with the counter. You could also drag a database table onto a page, and it will automatically create the necessary "plumbing" so that you can work with data from that table.

Figure 3.10. The Server Explorer window shows a list of servers, Windows services, databases, event logs, and more, available on your server or any server to which you can attach.


Properties Window
The Properties window provides a visual means of investigating and altering the properties of any object within the Visual Studio .NET environment. You can display the Properties window using the View, Properties Window menu item. Once this window is visible, you can either view the list alphabetically or categorized by attribute. Some properties within this window can be selected from a list; others allow you to click a button that brings up a dialog box. Still others require you to supply text by typing into a text box. Figure 3.11 shows the Properties window.

Figure 3.11. The Properties window is where you will spend a lot of time.


Object Browser Window
Similar to the Class View window, the Object Browser window shows you a list of classes and their respective members. The main difference between these two tools is that the Object Browser allows you to browse all referenced components, not just the components for the current project like the Class View window does. A nice feature of the Object Browser is that it also shows you the full declaration for the method or property. Bring up the Object Browser by using the View, Other indows, Object Browser menu item. Figure 3.12 shows the Object Browser window in use.

Figure 3.12. The Object Browser shows you a complete list of all classes, properties, and methods in your project.


Task List Window
The Task List window displays, among other items, any To Do items that you have entered in your code. In addition, you'll see information about build errors in this window. Bring up the Task List window using the View, Other Windows, Task List menu item. You will then see a window in your design environment similar to the one shown in Figure 3.13. To add a new task, you can click where the window reads "Click here to add a new task," or you can add comments in a specific format right in your project code. The default comment that adds to the Task List looks like his:

'TODO: Write the RepeaterBind procedure here

Figure 3.13. Tasks can help you organize your thoughts on what needs to be done to complete your project.


Use TODO: after the comment mark (the apostrophe), and the Task List will display your comment. You can double-click a task in the Task List window to take you directly to the associated comment in your code.

TIP

You can create your own Task List items using the Tools, Options menu item.
Within the Options dialog box, select Environment, Task List in the left pane. In the right pane, add new items. By default, Visual Studio .NET uses HACK, TODO, and UNDONE as Task List indicators. Add your own tag items to this list and click the Add button to make them available as tags that link comments in your code with the Task List.
Trackback: http://tb.blog.csdn.net/TrackBack.aspx?PostId=470790

上一篇[規則抽取]    下一篇 [賜姓]

相關評論

同義詞:暫無同義詞