標籤: 暫無標籤

EIGRPv6--屬於一個支持IP,IPX,Appletalk等多種網路的路由協議,基於EIGRP的大量部署,產生了讓EIGRP擴展TLV的方式來支持IPv6的想法。

1 EIGRPv6 -EIGRPv6簡介

  EIGRP本身屬於一個支持IP,IPX,Appletalk等多種網路的路由協議,基於EIGRP的大量部署,產生了讓EIGRP擴展TLV的方式來支持IPv6的想法。(IOS 12.4(6)T已經開始支持EIGRPv6)

  由於EIGRP的模塊化結構,如下圖:

  

EIGRPv6

EIGRP實現IPv6僅需要定義一個新的協議模塊即可。它在IPv6協議棧中引入,協議標識符依舊為88。同時增加了3個TLV,

  IPv6_Request_type

  IPv6_Metric_type

  IPv6_Exterior_type

  但和IPv4的EIGRP相同,使用同樣的32位的RouterID,使用同樣的Metric計算方式,同時也只能支持基於MD5的加密認證方式,而OSPFv3可以使用IPSec,IPSec的認證方式在EIGRPv6不可用。但Cisco將在以後的版本中支持IPSec的認證方式。

  EIGRPv6和EIGRP也有很多不同點,首先,它使用鏈路地址作為Hello報文的源地址,目的地址為組播地址FF02::A。這樣所有的鄰居並不需要相同的前綴來建立鄰居關係。同時自動匯總在IPv6環境中默認被關閉。

  由於IPv6模式下支持單條鏈路多個地址前綴,所以IPv6並不支持水平分割。

2 EIGRPv6 -EIGRPv6配置

EIGRPv6基本配置

  首先在全局模式,開啟ipv6單播轉發

  Router(config)#ipv6 unicast-routing

  此後可以開啟Cisco的快速轉發,

  Router(config)#ipv6 cef

  開啟EIGRPv6進程的方式和OSPFv3相似,均在介面上配置,將介面划入EIGRP的某個自治系統即可,但是需要注意的是,開啟完后,無論介面狀態是Down還是up,均需要使用No Shutdown命令來激活EIGRPv6進程。

  Router(config-if)# ipv6 eigrp as-number

  Router(config-if)#no shutdown

  Router-ID的選擇方式和EIGRPv4相同,但是當路由器中沒有任何32位ip地址存在時,進程因為無法制定Router-ID,會導致無法啟動,此時可以在EIGRPv6進程中,手工設置Router-ID。

  ipv6 router eigrp as-number

  router-id {ip-address | ipv6-address}

  no shutdown

  查看EIGRP信息如下:

  Router1#show ipv6 protocol

  IPv6 Routing Protocol is "eigrp 100"

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100

  EIGRP maximum metric variance 1

  Interfaces:

  FastEthernet0/1.1

  Redistribution:

  None

  Maximum path: 16

  Distance: internal 90 external 170

EIGRPv6地址匯總

  EIGRPv6同樣支持基於鏈路的地址匯總功能,命令如下

  ipv6 summary-address eigrp as-number ipv6-address[admin-distance]

EIGRPv6認證

  EIGRPv6僅支持MD5的認證方式

  首先需要定義一個Key-Chain

  key chain kaka

  key 1

  key-string mike

  accept-lifetime 16:30:00 Nov 28 2004 duration 43200 (持續43200秒)

  send-lifetime 16:30:00 Nov 28 2004 duration 43200

  key 2

  key-string mmike

  accept-lifetime 04:00:00 Nov 29 2004 13:00:00 Apr 15 2005(到期時間)

  send-lifetime 04:00:00 Nov 29 2004 13:00:00 Apr 15 2005

  key 3

  key-string mmmike

  accept-lifetime 12:30:00 Apr 15 2005 infinite (永遠)

  send-lifetime 12:30:00 Apr 15 2005 infinite

  從一個鑰匙到另一個鑰匙的遷移(鑰匙號從低到高檢查) ,系統允許 30min的時間重疊來在不同的系統始終之間校正

  此後需要在介面下激活MD5認證方式

  ipv6 authentication mode eigrp as-number md5

  如果該命令不執行,鏈路將不會使用認證

  然後將Key-chain掛接到需要認證的介面上

  ipv6 authentication key-chain eigrp as-number key-chain

EIGRPv6設置下一跳

  默認情況下EIGRPv6通告路由條目時將下一跳的地址,定義為該路由器的出口地址,可以通過如下命令改變

  no ipv6 next-hop-self eigrpas-number

EIGRPv6參數調整

  EIGRPv6和EIGRP類似,還可以對鏈路帶寬佔用進行定義,默認佔用為50%

  ipv6 bandwidth-percent eigrp as-number percent number

  EIGRPv6的Hello間隔時間配置i

  ipv6 hello-interval eigrp as-number seconds

  EIGRPv6的Hold計時器配置

  ipv6 hold-time eigrp as-number seconds

  關閉EIGRPv6的水平分割

  no ipv6 split-horizon eigrp as-number

EIGRPv6 Stub模式

  為了防止sia狀態的產生,EIGRPv6也可以配置Stub模式

  ipv6 router eigrp as-number

  stub [receive-only | connected |static | summary | redistributed]

監控EIGRPv6

  可以通過log消息監控EIGRPv6的鄰居變化和鄰居通告

  ipv6 router eigrp as-number

  log-neighbor-changes

  log-neighbor-warnings [seconds]

調整EIGRPv6 Metric

  EIGRPv6的度量方式和EIGRPv4完全相同,配置方式相似:

  ipv6 router eigrp as-number

  metric weights tos k1 k2 k3 k4 k5

Debug EIGRPv6

  debug eigrp FSM

  debug eigrp neighbor [siatimer] [static]

  debug eigrp packet

  debug eigrp transmit [ack] [build] [detail] [link] [packetize] [peerdown][sia] [startup] [strange]

  debug ipv6 eigrp [as-number] [neighbor ipv6-address | notification |summary]

  CCIE R/S & Service Provider Exam Certification Guide

3 EIGRPv6 -EIGRPv6配置實例

  如圖所示

  

EIGRPv6

Taos路由器的配置如下

  ipv6 unicast-routing

  interface e0

  ipv6 address 2001:db8:0:6::1/64

  ipv6 eigrp 1

  no shutdown

  interface e1

  ipv6 enable

  ipv6 eigrp 1

  no shutdown

  interface e2

  ipv6 address 2001:db8:0:5::1/64

  ipv6 eigrp 1

  no shutdown

  !

  ipv6 router eigrp 1

  router-id 10.1.1.1

  no shutdown

  Sandia路由器可以做如下配置

  ipv6 unicast-routing

  interface e0

  ipv6 address 2001:db8:0:4::1/64

  ipv6 eigrp 1

  no shutdown

  !

  ipv6 router eigrp 1

  router-id 10.1.1.1

  stub summary

  no shutdown__
上一篇[Email系統]    下一篇 [EGE]

相關評論

同義詞:暫無同義詞